Archive for the ‘CentOS’ category

Install php and fastcgi on CentOS 7

April 26th, 2017

This assumes you already installed CentOS 7.

to get fastcgi and php do the following:

yum install epel-release  
yum install openssh-clients rsync net-tools mc iptraf htop nc ifconfig wget
yum install php-xcache httpd php-mbstring php-bcmath php-mysql php-xml php-xmlrpc php-pecl-memcached php-pecl-memcache php  php-cli php-fpm  mod_fcgid

vi /etc/httpd/conf.d/php.conf

# line 5: change like follows

#    SetHandler application/x-httpd-php
    SetHandler "proxy:fcgi://127.0.0.1:9000" 



systemctl start php-fpm
systemctl enable php-fpm
systemctl restart httpd
systemctl enable  httpd
if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz

Redhat – Remove all i386 packages

December 4th, 2012

Sometimes 386 packages are installed by accident. This can cause issues during an update.

To remove them simply type:

yum remove \*.i\?86

Once complete, add the following to the top of the yum.conf file (/etc/yum.conf).

exclude = *.i?86
if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz

CentOS – Command line network configuration tool

July 8th, 2010

To change/edit network settings from the command line using a configuration tool type:

system-config-network
if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz

Linux – CentOs/Redhat – rpm dependencies search

March 20th, 2010

To find the dependencies on a package (rpm) type :

rpm -Uvh *

In the folder were you downloaded them too.

To search for dependencies based on partial knowledge

yum search name

if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz

CentOS -Mod_SSL install error Missing Dependency: httpd = etc….

January 29th, 2010

If you are trying to install Mod_SSL on CentOS you will sometimes get the following error. The error will look something like this:

Finished Dependency Resolution
httpd-devel-2.2.3-31.el5.centos.2.i386 from updates has depsolving
problems
–> Missing Dependency: httpd = 2.2.3-31.el5.centos.2 is needed by
package httpd-devel-2.2.3-31.el5.centos.2.i386 (updates)
Error: Missing Dependency: httpd = 2.2.3-31.el5.centos.2 is needed by
package httpd-devel-2.2.3-31.el5.centos.2.i386 (updates)

So if you run into this issue you can try one of 2 things, the easiest is too run:

yum clean all

Then try again.

Alternatively, you can install the package that is missing manually. In this example it would be:

yum install http-devel.x86_64

Once you run this try and re-install mod_ssl.

This is generally caused because yum will sometimes have problems finding the dependencies on 64bit versions of the OS

if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz