Posts Tagged ‘Plesk SSL error’

Plesk and DrWeb will not start

April 2nd, 2010

On a test server of mine i found that Plesk and Drweb would not start. I was getting the following start

/etc/init.d/psa start
Starting xinetd service...                                            done
Starting named service...                                             done
Starting mysqld service...                                            done
Starting postgresql service...                                        done
Starting psa-spamassassin service...                                  done
Plesk: Starting Mail Server... already started
Starting mail handlers tmpfs storage
Starting Plesk...                                                     failed
Starting drwebd service...                                            failed

When checking the error_log i found:

tail -f /var/log/sw-cp-server/error_log
2010-03-30 20:26:36: (log.c.75) server started
2010-03-30 20:26:36: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
2010-03-30 20:29:55: (log.c.75) server started
2010-03-30 20:29:55: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
2010-03-30 20:29:55: (log.c.75) server started
2010-03-30 20:29:55: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
2010-03-30 20:37:57: (log.c.75) server started
2010-03-30 20:37:57: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)
2010-03-30 20:37:57: (log.c.75) server started
2010-03-30 20:37:57: (network.c.336) SSL: error:00000000:lib(0):func(0):reason(0)

It turns out that Plesk has an issue with a new openssl version, the exact version is

openssl-0.9.8e-12.el5_4.6

If you run:

rpm -qa | grep openssl

And find that the result is the above SSL

rpm -qa | grep openssl
openssl-0.9.8e-12.el5_4.6

downgrade the open ssl to 4.1 (IMPORTANT: if you see any psa/plesk packages listed in teh dependency youll need to use a different method, look at the end of the page for details)

yum downgrade openssl-0.9.8e-12.el5_4.1

This should fix it and Plesk will start

Method 2:

If you find that tring to run yum downgrade openssl-etc… lists some psa/plesk dependencies then you will need to do the following:

# wget -c http://mirrors.kernel.org/centos/5/updates/x86_64/RPMS/
{openssl-0.9.8e-12.el5_4.1.x86_64.rpm,mod_ssl-2.2.3-31.el5.centos.2.x86_64.rpm,httpd-
2.2.3-31.el5.centos.2.x86_64.rpm}

# rpm -Uvh --oldpackage {openssl-0.9.8e-12.el5_4.1.x86_64.rpm,mod_ssl-
2.2.3-31.el5.centos.2.x86_64.rpm,httpd-2.2.3-31.el5.centos.2.x86_64.rpm}

# /etc/init.d/sw-cp-server start
if you found this helpful feel free to donate to:
ZEC: t1NQp1UuqQbmnXzazbLTSreS2AbaZpRBuTM
LTC: LZyNF1qkBUA7XFz83m5xwzGgmmj1owQn9d
BTC: 1PY95KFPTEJTR7f2NnSgaB6xB9pwDJkcJz